关于Android studio的Could not find com.android.tools.build:gradle:x.x.x.避坑(已解决)导入别人的项目频频报错?

在这里插入图片描述
如果在导入别人的项目是,出现以上错误!

Could not find com.android.tools.build:gradle:4.0.0.
Searched in the following locations:
  - https://jcenter.bintray.com/com/android/tools/build/gradle/4.0.0/gradle-4.0.0.pom
  - https://jcenter.bintray.com/com/android/tools/build/gradle/4.0.0/gradle-4.0.0.jar
Required by:
    project :
Add Google Maven repository and sync project
Open File

不要慌…
只需要在build.gradle(project)两处加上google(),还有 maven {
url “https://maven.google.com”
}
完整的如下:

// Top-level build file where you can add configuration options common to all sub-projects/modules.
buildscript {
    repositories {
        jcenter()
         maven {
            url "https://maven.google.com"
        }
        google()
    }
    dependencies {
    //3.5.2是我as的版本,你可以把它改成你用的版本
        classpath 'com.android.tools.build:gradle:3.5.2'
    }
}

allprojects {
    repositories {
        jcenter()
        google()
    }
}

同步一下
在这里插入图片描述
当改完同步一下之后,会出现另一个错误…
别慌!
看看是什么错误?

Minimum supported Gradle version is 5.4.1. Current version is 4.8.

Please fix the project's Gradle settings.
Fix Gradle wrapper and re-import project
Open Gradle wrapper properties
Gradle settings

在这里插入图片描述
只要在gradle-wrapper.properties里把我圈起来的改成上面提示的5.4.1-all
如下:

distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-5.4.1-all.zip
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists

注意啦,修改的版本一定要是报错信息提示的版本,不要照抄我的版本!

接着再同步一下!
wow,又一个警告出现了,我们去看看…
在这里插入图片描述

The project encoding (UTF-8) has been reset to the encoding specified in the Gradle build files (UTF-8).
Mismatching encodings can lead to serious bugs.

这个是因为代码编码的原因…
在build.gradle(app)加上compileOptions.encoding = "UTF-8"
如下:
在这里插入图片描述
到这里的时候,会看到targetSdkVersion 8,那个8变红了!
那就改!
我改成和 我版本对应的28。为什么我的是28?其实你想知道你支持的版本是什么,你只要new一个新的empty activity工程,就可以看到自己相对应的版本啦!

改完之后,上面的compileSdkVersion 14 又红啦!compileSdkVersion要和targetSdkVersion 一致的!
所以也改成28.
minSdkVersion 改成15
然后再看下面的compile 'com.android.support:support-v4:18.0.0'又红了

Alt+Enter,点击第一项replace with x.x.x
在这里插入图片描述
如果你的compile没有被划线,那就不用管它,如果被划线了,就Alt+Enter,点击第一项,

replace ‘compile ’with ‘implementation’

改完之后是这样的:

dependencies {
    implementation 'com.android.support:support-v4:28.0.0'
    implementation files('libs/activation.jar')
    implementation files('libs/additionnal.jar')
    implementation files('libs/Android_SDK_v1.2.jar')
    implementation files('libs/appkefu_im_sdk.jar')
    implementation files('libs/core.jar')
    implementation files('libs/httpmime-4.1.3.jar')
    implementation files('libs/mail.jar')
    implementation files('libs/MiPush_SDK_Client_2_2_5_sdk.jar')
}

再同步一下!
如果又出现了以下错误:

The minSdk version should not be declared in the android manifest file. You can move the version from the manifest to the defaultConfig in the build.gradle file.
Remove minSdkVersion and sync project
Affected Modules: app

在manifest 文件把我画出来的东西删掉即可!
在这里插入图片描述
再同步一下,没有报错了!
哈哈哈!

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页
实付 19.90元
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值